Cisco Integrated IS-IS

What’s IS-IS?
Is it a militant group in Syria? No..No…
It’s a routing protocol, Intermediate System to Intermediate System (IS-IS). When people talking about Link State routing protocol, most of them are thinking about OSPF. In fact, another link state routing protocol is exist. Yeaah.. IS-IS!

Well, I don’t want to waste our time. In this session, I will show you how to configure IS-IS routing protocol in Cisco router. For the details about IS-IS, I recommend you to read “Routing TCP/IP, Vol-1 (CCIE Professional Development)” by Jeff Doyle, Cisco Press. OK, please refer to the following topology during my lab session:

TOPOLOGY

R1 and R2 are located in the backbone network, so they are considered as IS-IS L2 type router. While R3 and R6, they are located inside an area network (we call it as stub-network in OSPF). So that, we categorize them as L1 type router. Last but not least, R4 and R5 are called as L1/L2 type router. It’s because they are connecting between L1 and L2 area network, in OSPF we naming it as ABR. Now, it’s time for configuration part!

CONFIGURATION
  • R1
hostname R1
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.252
 ip router isis 
 duplex full
!
interface GigabitEthernet1/0
 ip address 14.14.14.1 255.255.255.248
 ip router isis 
 negotiation auto
!
router isis 
 net 49.0001.ca01.05e8.001c.00
 is-type level-2-only
  • R2
hostname R2
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.252
 ip router isis 
 duplex full
!
interface GigabitEthernet1/0
 ip address 25.25.25.2 255.255.255.248
 ip router isis 
 negotiation auto
!
router isis 
 net 49.0001.ca02.23a8.001c.00
 is-type level-2-only
  • R3
hostname R3
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 34.34.34.3 255.255.255.240
 ip router isis 
 duplex full
!
router isis 
 net 49.0002.ca03.1948.0000.00
 is-type level-1
  • R4
hostname R4
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 34.34.34.4 255.255.255.240
 ip router isis 
 duplex full
!
interface GigabitEthernet1/0
 ip address 14.14.14.4 255.255.255.248
 ip router isis 
 negotiation auto
!
router isis 
 net 49.0002.ca04.167c.001c.00

In Cisco router, the is-type value is L1/2 by default. So we don’t need to specify it at R4 and R5.

  • R5
hostname R5
!
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 56.56.56.5 255.255.255.240
 ip router isis 
 duplex full
!
interface GigabitEthernet1/0
 ip address 25.25.25.5 255.255.255.248
 ip router isis 
 negotiation auto
!
router isis 
 net 49.0003.ca05.00d8.001c.00
  • R6
hostname R6
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip router isis 
!
interface FastEthernet0/0
 ip address 56.56.56.6 255.255.255.240
 ip router isis 
 duplex full
!
router isis 
 net 49.0003.ca06.292c.0000.00
 is-type level-1

OK, look at the configurations carefully! We need to specify net address under router isis process. There are three components in IS-IS network addressing format:

  • Area Identifier: The first three bytes are the area ID. The first byte of this example — 49 — is the address family identifier (AFI) of the authority, which is equivalent to the IP address space that is assigned to an autonomous system. The AFI value 49 is what IS-IS uses for private addressing, which is the equivalent of RFC 1918 address space for IP protocols. The second two bytes of the area ID — 0001 — represent the IS-IS area number. In this example, the area number is 1.
  • System Identifier: The next six bytes identify the node (that is, the router) on the network. The system identifier is equivalent to the host or address portion on an IP address. Although you can choose any value for the system identifier, a commonly used method is to use binary-coded decimal (BCD) which involves taking the router’s IP address (the address you assigned to the lo0 loopback interface), filling in all leading zeros, and then repositioning the decimal points to form three two-byte numbers. In this example, if you pad the IP address 192.168.1.2 with zeros, the result is 192.168.001.002. Rearranging the decimal points gives you 1921.6800.1002. In my case, I’m using one of interface’s MAC address on each router.
  • NET Selector: The final two bytes are the NET selector (NSEL). For IS-IS, they must always be 00, to indicate “this system.”
VERIFICATION

Please type these following commands to do troubleshooting for IS-IS routing protocol. In my case, I just want to ping from loopback’s IP of R3 to loopback’s IP of R6 and vice versa. So, I just want to show you the command output on those two devices. You can check the other devices using same method.

  • R3
R3#show clns is-neighbors 

System Id Interface State Type Priority Circuit Id Format
R4 Fa0/0 Up L1 64 R4.02 Phase V
R3#
R3#
R3#
R3#show ip route isis
 4.0.0.0/32 is subnetted, 1 subnets
i L1 4.4.4.4 [115/20] via 34.34.34.4, FastEthernet0/0
 14.0.0.0/29 is subnetted, 1 subnets
i L1 14.14.14.0 [115/20] via 34.34.34.4, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 34.34.34.4, FastEthernet0/0
R3#show isis database

IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R3.00-00 * 0x00000005 0x8DC8 975 0/0/0
R4.00-00 0x00000005 0xA891 716 1/0/0
R4.02-00 0x00000003 0x7AAE 940 0/0/0
R3#
R3#
R3#ping 6.6.6.6 source 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Packet sent with a source address of 3.3.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 124/156/184 ms
R3#
R3#
R3#
R3#tracerou
R3#traceroute 6.6.6.6 source 3.3.3.3

Type escape sequence to abort.
Tracing the route to 6.6.6.6

 1 34.34.34.4 16 msec 32 msec 36 msec
 2 14.14.14.1 60 msec 60 msec 64 msec
 3 12.12.12.2 124 msec 92 msec 92 msec
 4 25.25.25.5 120 msec 128 msec 124 msec
 5 56.56.56.6 160 msec 108 msec 168 msec
R3#
  • R6
R6#show clns is-neighbors

System Id Interface State Type Priority Circuit Id Format
R5 Fa0/0 Up L1 64 R6.02 Phase V
R6#
R6#
R6#
R6#show ip route isis
 5.0.0.0/32 is subnetted, 1 subnets
i L1 5.5.5.5 [115/20] via 56.56.56.5, FastEthernet0/0
 25.0.0.0/29 is subnetted, 1 subnets
i L1 25.25.25.0 [115/20] via 56.56.56.5, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 56.56.56.5, FastEthernet0/0
R6#
R6#
R6#sho isis database

IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R5.00-00 0x00000008 0xB227 576 1/0/0
R6.00-00 * 0x00000005 0x4711 558 0/0/0
R6.02-00 * 0x00000003 0xE85B 553 0/0/0
R6#
R6#
R6#
R6#ping 3.3.3.3 source 6.6.6.6

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 6.6.6.6 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/168/192 ms
R6#
R6#
R6#
R6#traceroute 3.3.3.3 source 6.6.6.6

Type escape sequence to abort.
Tracing the route to 3.3.3.3

 1 56.56.56.5 32 msec 32 msec 32 msec
 2 25.25.25.2 52 msec 64 msec 56 msec
 3 12.12.12.1 100 msec 88 msec 100 msec
 4 14.14.14.4 128 msec 132 msec 128 msec
 5 34.34.34.3 144 msec 164 msec 156 msec
R6#

Voila!!! Your IS-IS routing protocol is working..

Reference:

Routing TCP/IP, Vol-1” by Jeff Doyle, Cisco Press.

http://www.dummies.com/programming/networking/juniper/is-is-network-protocol-basics/

Advertisements