Cisco IS-IS IPv6

Previously, I have posted a basic configuration of IS-IS routing protocol on Cisco router. In this session, I want to share my experience with Cisco IS-IS over IPv6 because this tutorial is also part of CCIE lesson. If you’re not familiar with IS-IS, I suggest you to read my previous posting and read Cisco documentation about IS-IS. Basic knowledge on IPv6 addressing is not mandatory, but it will be helpful.

TOPOLOGY

Based on the topology above, I have two different level areas. R1 and R2 are running IS-IS protocol inside an area 49.0001 which is Level-2 area. R3 and R4 are border router for their own area ID, so they’re assigned as Level-1-2 router. All routers will be assigned using IPv6 addressing on its interface to communicate each other. Basically, the IS-IS routing protocol configuration for IPv6 is about the same with IPv4 configuration. Please refer to the following configuration on each router:

CONFIGURATION
  • R1
hostname R1
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1111:1:1:1::1/96
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address 1212:12:12:12::1/64
 ipv6 router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1/0
 no ip address
 negotiation auto
 ipv6 address 1313:13:13:13::1/64
 ipv6 router isis 
 isis circuit-type level-2-only
!
router isis 
 net 49.0001.ca01.05e8.001c.00
 is-type level-2-only
  • R2
hostname R2
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2222:2:2:2::2/96
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address 1212:12:12:12::2/64
 ipv6 router isis 
 isis circuit-type level-2-only
!
interface GigabitEthernet1/0
 no ip address
 negotiation auto
 ipv6 address 2424:24:24:24::2/64
 ipv6 router isis 
 isis circuit-type level-2-only
!
router isis 
 net 49.0001.ca02.23a8.001c.00
 is-type level-2-only
  • R3
hostname R3
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3333:3:3:3::3/96
!
interface FastEthernet0/0
 no ip address
 duplex half
!
interface GigabitEthernet1/0
 no ip address
 negotiation auto
 ipv6 address 1313:13:13:13::3/64
 ipv6 router isis 
!
router isis 
 net 49.0002.ca04.167c.001c.00
  • R4
hostname R4
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 4444:4:4:4::4/96
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex full
!
interface GigabitEthernet1/0
 no ip address
 negotiation auto
 ipv6 address 2424:24:24:24::4/64
 ipv6 router isis 
!
router isis 
 net 49.0003.ca05.00d8.001c.00
VERIFICATION

These are standard commands that you can use to verify:

show ipv6 interface brief
show clns neighbors
show clns interface [interface_name]
show ipv6 route
show isis ipv6 topology
show isis database detail
debug isis adj-packets

In this scenario, the main objective is to reach R4’s interface from R3’s interface. So, I just need to execute ping command from R3 or R4:

R3#ping 2424:24:24:24::4 source gigabitEthernet 1/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2424:24:24:24::4, timeout is 2 seconds:
Packet sent with a source address of 1313:13:13:13::3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/83/112 ms

R4#ping ipv6 1313:13:13:13::3 source gi1/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1313:13:13:13::3, timeout is 2 seconds:
Packet sent with a source address of 2424:24:24:24::4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/90/108 ms
Reference:

Configuring IS-IS over IPv6, by Cisco Systems.

Advertisements