Cisco Nexus vPC

Kali ini saya akan sedikit berbagi pengalaman teknis terkait fitur dari product Cisco yang lagi booming, yaitu vPC (Virtual Port Channel). vPC ini merupakan salah satu fitur yang ada pada perangkat Cisco Nexus, salah satunya Nexus 7000. *Kebetulan ditempat customer adanya seri 7010 & 7018.

Fitur vPC ini sebenarnya mirip-mirip dengan fitur VSS di Cisco Catalyst 6500, untuk perbedaannya akan kita bahas dilain kesempatan. Pada dasarnya, vPC ini menggabungkan dua devices yang terhubung ke suatu perangkat network/server melalui Etherchannel atau Link Aggregation. Untuk lebih jelasnya bisa melihat pada topologi berikut :

vPC-Nexus

Pada umumnya link aggregation terbentuk antara dua perangkat yang memiliki beberapa interkoneksi satu sama lain. Adapun beberapa istilah yang ada dalam vPC, antara lain :

  • vPC : gabungan portchannel antara vPC Peer devices (Cisco Nexus Switch) dan downstream devices (Switch 2960, Server, dsb.).
  • vPC Peer Switch : pasangan switch yang terhubung melalui portchannel khusus yang biasa disebut vPC Peer Link, dalam topologi di atas yaitu N7K-A dan N7K-B. Salah satu device akan dipilih sebagai Primary dan sisa beroperasi sebagai Secondary.
  • vPC Peer Link : link yang digunakan untuk men-synchronize state antara vPC peer devices. vPC Peer Link bertanggung jawab untuk mengontrol traffic antara dua vPC switches dan juga mengontrol traffic multicast, broadcast, unicast (pada kasus tertentu). Untuk membentuk suatu peer link, minimal kita harus memiliki dua interfaces 10G.
  • vPC Domain : dalam vPC domain biasanya terdiri dari vPC Peer Devices, vPC Peer Keepalive, dan semua portchannel di dalam vPC yang terhubung ke perangkat lain.
  • vPC Peer Keepalive : berfungsi untuk memonitor kondisi antara vPC peer switch dengan mengirimkan keepalive message secara periodic. Dalam peer keepalive tidak ada pertukaran data atau synchronization traffic, jadi hanya murni keepalive message untuk mendeteksi status antara dua perangkat switch yang sedang menjalankan vPC. vPC Peer Keepalive bisa kita configure menggunakan interface management atau SVI (interface vlan).
  • vPC Port Member : port yang masuk dalam vPC, dalam topologi di atas yaitu Eth1/1, Eth1/2, Fa1/0, Fa1/1, dst.

Itulah sedikit istilah-istilah yang ada dalam vPC. Penggunaan teknologi ini memiliki beberapa keuntungan, antara lain :

  • Mengijinkan suatu perangkat terhubung ke dua perangkat berbeda menggunakan link aggregation, dimana kedua link tersebut bersifat loadbalance (active-active).
  • Tidak ada spanning-tree, semua port yang terkoneksi dalam vPC member dalam kondisi FORWARDING.
  • Loop-free topology.
  • Meng-utilize semua uplink bandwidth.
  • Fast convergence, in case terjadi devices failure.
  • High availability.

OK, saya rasa Anda mulai bosan dengan sedikit teori di atas. Sekarang kita saatnya masuk ke tahap praktek, untuk meng-configure vPC bisa mengikuti langkah-langkah berikut :

1.       Mengaktifkan fitur vPC

N7K-A#config term

N7K-A(config)#feature vpc

2.       Membuat vPC Domain

N7K-A(config)#vpc domain 3

3.       Membuat VRF Keepalive (Optional)

Agar lebih amannya, kita perlu membuat VRF tersendiri untuk Peer Keepalive. Pada Nexus 5000, VRF hanya dibatasi maximum 2 VRF yaitu default dan management. Sedangkan pada Nexus 7000 kita bisa membuat VRF tambahan.

N7K-A(config)#vrf context KEEPALIVE

4.       Configure vPC Peer Keepalive

N7K-A(config-vpc-domain)#peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf KEEPALIVE

5.       Configure System Priority (Optional)

N7K-A(config-vpc-domain)#system-priority 100

Configurasi system priority ini harus sama di kedua switch, jika berbeda vPC tidak akan aktif.

6.       Configure vPC Role Priority (Optional)

N7K-A(config-vpc-domain)#role priority 100

Role priority digunakan untuk menentukan primary or secondary device, semakin rendah nilai prioritynya maka device tersebut dipilih sebagai primary. Jika vPC Peer Link putus, maka vPC Peer akan mendeteksi apakah peer switch yang lain masih aktif/hidup melalui peer keepalive. Apabila Primary device masih aktif, maka Secondary switch akan men-suspend semua port member vPC. Sehingga semua vPC port aktif di Primary device. Hal ini bertujuan untuk mencegah terjadinya looping.

7.       Membuat vPC Peer Link

N7K-A(config)#interface port-channel 1

N7K-A(config-if)#vpc peer-link

N7K-A(config)#interface eth2/2

N7K-A(config-if)#channel-group 1 force mode active

8.       Memasukkan Port-channel ke dalam vPC

N7K-A(config)#interface eth1/2

N7K-A(config-if)#channel-group 200 force mode active

N7K-A(config-if)#interface port-channel 200

N7K-A(config-if)#vpc 2

OK, sampai sini apakah sudah bingung ? Kalau masih bingung berikut saya lampirkan full confignya :

N7K-A Configuration

feature vpc
feature lacp

vrf context KEEPALIVE

vpc domain 3
peer-keepalive destination 1.1.1.2 source 1.1.1.1 vrf KEEPALIVE
system-priority 100
role priority 95

interface port-channel 1
switchport
switchport mode trunk
vpc peer-link

interface port-channel 99
vrf member KEEPALIVE
ip address 1.1.1.1/30

interface port-channel 100
switchport
switchport mode trunk

interface port-channel 200
switchport
switchport mode trunk

interface eth1/1
switchport
switchport mode trunk
channel-group 100 force mode active
vpc 1

interface eth1/2
switchport
switchport mode trunk
channel-group 200 force mode active
vpc 2

inter eth2/1
channel-group 99 force mode active

inter eth2/2
channel-group 99 force mode active

inter eth2/3
switchport
switchport mode trunk
channel-group 1 force mode active

inter eth2/4
switchport
switchport mode trunk
channel-group 1 force mode active

N7K-B Configuration

feature vpc
feature lacp

vrf context KEEPALIVE

vpc domain 3
peer-keepalive destination 1.1.1.1 source 1.1.1.2 vrf KEEPALIVE
system-priority 100
role priority 105

interface port-channel 1
switchport
switchport mode trunk
vpc peer-link

interface port-channel 99
vrf member KEEPALIVE
ip address 1.1.1.2/30

interface port-channel 100
switchport
switchport mode trunk

interface port-channel 200
switchport
switchport mode trunk

interface eth1/1
switchport
switchport mode trunk
channel-group 200 force mode active
vpc 2

interface eth1/2
switchport
switchport mode trunk
channel-group 100 force mode active
vpc 1

inter eth2/1
channel-group 99 force mode active

inter eth2/2
channel-group 99 force mode active

inter eth2/3
switchport
switchport mode trunk
channel-group 1 force mode active

inter eth2/4
switchport
switchport mode trunk
channel-group 1 force mode active

Cat-2960 Configuration

inter po1
switchport mode trunk

inter range fa1/0 – 1
switchport mode trunk
channel-group 1 mode active

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s